Actualizar WordPress desde shell en menos de un minuto

Si deseamos actualizar varios WordPress en poco menos que un minuto podemos hacerlo desde la linea de comandos en Linux con este sencillo script en Bash: #!/bin/bash # Modifica las variables para tu sistema BLOG_DIR=/var/www/blog COPIA_DIR=/root/copiawp # No modifiques las variables FECHA=`date +%Y.%m.%d` INSTANCIA=$1 # si no hay variables, explica su uso y sal if …

Continuar leyendo

Plugins ¿qué son y para qué sirven?

Los plugins son unos pequeños o grandes programas que dotan a nuestro blog de utilidades diferentes de las que trae de fábrica. Son fundamentales porque permiten ver contenidos de las páginas web que el propio navegador no conseguiría mostrar sin ellos. Como vídeos, música, animaciones o aplicaciones. Existe una gran variedad de plugins para todo …

Continuar leyendo

Plantillas o temas de WordPress: Divi y Amy

Las plantillas o temas de WordPress son casi todas de vanguardia, interesantes e innovadoras. Es por ello que crear una web blog profesional es tarea fácil con las más de 2000 plantillas gratuitas que esta plataforma digital pone a disposición. Se puede crear un web blog que cause impresión y se haga destacar en toda …

Continuar leyendo

WordPress para Android: una combinación perfecta

WordPress es un CMS (Content Management System) que se utiliza principalmente para montar y administrar blogs, y que a poco a poco se ha hecho un espacio en este mundo virtual y se ha convertido en la plataforma más usada en esta área. Por ello, la empresa Automattic, en el año 2010, sacó al mercado …

Continuar leyendo

Vulnerabilidad que afecta a múltiples plugins de WordPress

Múltiples plugins de WordPress son vulnerables a Cross-site Scripting (XSS) debido al mal uso de la función add_query_arg () y remove_query_arg ()  . Estas funciones  suelen ser ultilizadas  por los desarrolladores para modificar y agregar cadenas de consulta para direcciones URL dentro de WordPress. La documentación oficial de WordPress oficial (Codex) para estas funciones no era …

Continuar leyendo

Alerta! Vulnerabilidad en fancybox-for-wordpress

Se ha detectado una nueva vulnerabilidad en plugin fancybox-for-wordpress y está afectando a miles de sitios web con malware, este plugin es muy popular y cuenta con más de 550.000 descargas! También hemos realizado algunos análisis en un ambiente controlado y la vulnerabilidad permite inyectar código malicioso a los archivos o núcleo del wordpress, en este caso al ser infectado …

Continuar leyendo